3rd Generation (2015+) Say hello to the newest member of the Fit family. 3rd Generation specific talk and questions here.

Anyone else get a loose engine splash shield under their car?

  #301  
Old 04-20-2018, 05:03 PM
Member
Join Date: Jul 2015
Location: Toronto
Posts: 275
My undertray blew out due to snow accumulation AGAIN! This time we had loads of freezing rain and tons of slushy ice on the roads.... I am off to canadian tire to buy another round of fasteners.
 
  #302  
Old 04-22-2018, 06:21 PM
Member
Join Date: Dec 2015
Location: godfrey, il
Posts: 141
Been ruminating on this issue.
I think the problem is hitting something like a curb with the shield. That loosens it, then it works it's way off.
Either that, or a technician doesn't reinstall it properly after an oil change.
I've taken to parking about a foot away from the curb.
So far so good.
 
  #303  
Old 04-22-2018, 06:24 PM
Member
Join Date: May 2016
Location: Raleigh, NC
Posts: 158
Originally Posted by max503 View Post
Been ruminating on this issue.
I think the problem is hitting something like a curb with the shield. That loosens it, then it works it's way off.
Either that, or a technician doesn't reinstall it properly after an oil change.
I've taken to parking about a foot away from the curb.
So far so good.
See too. I am paranoid about curbs and parking blocks.
 
  #304  
Old 04-22-2018, 07:17 PM
Member
Join Date: Jun 2016
Location: Foothills of the Smokies, east Tennessee
Posts: 677
Mine was missing when I bought the car CPO ....problem solved
 
  #305  
Old 04-24-2018, 01:59 AM
Member
Join Date: Jul 2014
Location: Michigan
Posts: 82
Just submitted the NHTSA Vehicle Complaint Form in regards to this issue.
 
  #306  
Old 05-08-2018, 11:56 AM
Member
Join Date: Dec 2015
Location: Northern Michigan
Posts: 102
2016 LX mt, 25,606. Had oil changed 3/15/18 and last night heard a funny ticking noise. Got home, looked under car and sure enough, the shield was drooping. Was at my auto repair shop at 8 am this morning - was fixed in 15 minutes at no charge. My mechanic said the fasteners just wear out so he installed new ones.
 
  #307  
Old 11-30-2018, 11:01 AM
Member
Join Date: Jan 2018
Location: Huntington Beach, CA
Posts: 38
Mine's loose now. Anyone know where I can find sturdy, exact fitting parts for cheap?
 
  #308  
Old 11-30-2018, 12:07 PM
wasserball's Avatar
Member
Join Date: Nov 2016
Location: Friendswood, TX
Posts: 665
This thread is still going strong.
 
  #309  
Old 11-30-2018, 12:14 PM
wasserball's Avatar
Member
Join Date: Nov 2016
Location: Friendswood, TX
Posts: 665
Originally Posted by Fuelish View Post
Mine was missing when I bought the car CPO ....problem solved
The SA was stunned when I told him not to reinstall the undercover after the first free oil change. Now, I can change the oil in less than 15 minutes and without having to lift up the car.
 
  #310  
Old 11-30-2018, 01:08 PM
Member
Join Date: Jul 2014
Location: Shokan, NY
Posts: 2,194
Originally Posted by wasserball View Post
The SA was stunned when I told him not to reinstall the undercover after the first free oil change. Now, I can change the oil in less than 15 minutes and without having to lift up the car.
Sure, but your gas mileage will drop 50%. (Kidding, of course)
 
  #311  
Old 11-30-2018, 03:23 PM
Fitster C.'s Avatar
Member
Join Date: Jan 2015
Location: Doraville
Posts: 367
Let it Be

Originally Posted by Gekisen View Post
Mine's loose now. Anyone know where I can find sturdy, exact fitting parts for cheap?
You have probably seen my decision to ditch the cover from several other Fit Freaks. Mine came off twice (parking abutment first time and deceased groundhog the second). I knew the installation design was flakey (still love the car) from other Fit Freak posters, and asked my mechanic friends at Atlanta Auto Pro (Honda only shop) if ditching the lid was OK. OK from them, so I threw the damaged cover away and have had no problem since. Might reconsider if living up north with lots of ice and snow, but that is probably yet another cover-problem trigger as well. The incredible $500-700 dealer charge for repair is unwarranted, and my search for the part was like trying to patch up a space shuttle.
 
  #312  
Old 11-30-2018, 04:58 PM
wasserball's Avatar
Member
Join Date: Nov 2016
Location: Friendswood, TX
Posts: 665
Originally Posted by SilverEX15 View Post
Sure, but your gas mileage will drop 50%. (Kidding, of course)
But, I get a free engine wash when it rains.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Chiasson Cary
Honda Fit Dealer Representatives
3
06-13-2018 06:15 PM
TorontoBoy
3rd Generation (2015+)
15
06-12-2018 01:39 PM
defcon86nwh
3rd Generation (2015+)
16
11-07-2017 10:39 AM
SilverEX15
3rd Generation (2015+)
31
10-17-2017 05:28 PM
willy65000
1st Generation (GD 01-08)
9
02-12-2017 08:47 AM


Thread Tools
Search this Thread
Quick Reply: Anyone else get a loose engine splash shield under their car?


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.