How to fit your Scosche Kit properly, OMG IT FITS! - Page 2 - Unofficial Honda FIT Forums

Go Back  Unofficial Honda FIT Forums > Fit Modifications > Fit I.C.E.
Reload this Page >

How to fit your Scosche Kit properly, OMG IT FITS!

Fit I.C.E. Threads discussing in-car electronics including audio, video, security, and navigation systems for the Honda Fit/Jazz

How to fit your Scosche Kit properly, OMG IT FITS!

  #21  
Old 10-21-2008, 10:41 PM
CuTeBoi's Avatar
Member
5 Year Member
Thread Starter
iTrader: (1)
Join Date: Apr 2007
Location: San Antonio, TX, USA
Posts: 1,346
They are both good quality materials, just that Scosche didn't really offer a refund or exchange for the bad batch they had.

Some are still on store shelves, and nothing they will do about it.

Hope you guys don't have any issues with the newer batches.

And for those wanting pics, there are plenty of other threads out there with those pictures.

And if you are having fitment issues, you haven't done the repair properly,
@FITSTER: Why not post pictures of YOUR install, lets see where the problem is.
 
  #22  
Old 10-23-2008, 09:11 PM
moegenki's Avatar
Member
Join Date: Apr 2008
Location: Secret Underground VIP Crepe Shop
Posts: 87
Originally Posted by rekcah View Post
I just got my kit from Scosche this week. They just did the same cutting showed in this thread.


The price was good $63.39 shipped with wire harness and ant extender.
Got a link to that? It was about 100 bucks at scosche's website. Thanks
 
  #23  
Old 10-24-2008, 02:29 AM
CuTeBoi's Avatar
Member
5 Year Member
Thread Starter
iTrader: (1)
Join Date: Apr 2007
Location: San Antonio, TX, USA
Posts: 1,346
I'm selling mine for 50$, if you're interested.

I have it already cut, and it has the harness for the stereo, and the antenae.

It is already cut to be fit. All that is needed is that you use a few of your stock clips to attach to the upper right side of the kit.

Originally Posted by moegenki View Post
Got a link to that? It was about 100 bucks at scosche's website. Thanks
 
  #24  
Old 10-24-2008, 12:15 PM
gimme's Avatar
Administrator
5 Year Member
iTrader: (13)
Join Date: Jun 2006
Location: Phoenix
Posts: 4,253
the kit has OKAY fitment. I have one and there are a few changes i would make to it. like the "recirc" sticker falling off and getting lost, would be one.

but schosche stood up and backed their product. I asked how i could buy a sticker and they sent me the whole damn kit
 
  #25  
Old 10-24-2008, 04:23 PM
CuTeBoi's Avatar
Member
5 Year Member
Thread Starter
iTrader: (1)
Join Date: Apr 2007
Location: San Antonio, TX, USA
Posts: 1,346
Yours too???

I thought mine was a fluke, get a replacement from honda, don't remember the cost, but it wasn't that much.
 
  #26  
Old 10-24-2008, 05:07 PM
gimme's Avatar
Administrator
5 Year Member
iTrader: (13)
Join Date: Jun 2006
Location: Phoenix
Posts: 4,253
Originally Posted by CuTeBoi View Post
Yours too???

I thought mine was a fluke, get a replacement from honda, don't remember the cost, but it wasn't that much.
they sell just those little decals? I would rather have them the grey'sih color than the scosche blak. please say you can scrounge up the part number
 
  #27  
Old 12-29-2008, 08:27 PM
pwnstar's Avatar
Member
iTrader: (3)
Join Date: Apr 2008
Location: uniontown PA
Posts: 873
ok i have a question do all of these kits NOT fit? or just some? becouse im getting my kit in the mail tomorow to get my unit put in but im not putting it in and i wanna make sure its gonna fit good becouse i know the guys putting it in are not going to do this to get ti to work so if i do all of this before hand before i take it there will it hurt? will it be more messed up if it was right in the first place or will it not matter either way? could somone please let me know ASAP thanks
 
  #28  
Old 12-30-2008, 09:29 AM
MorningZ's Avatar
Member
5 Year Member
Join Date: Jun 2008
Location: Ft Lauderdale
Posts: 29
"becouse i know the guys putting it in are not going to do this to get ti to work"

Maybe it's time to find a new installer then
 
  #29  
Old 12-30-2008, 09:51 AM
pwnstar's Avatar
Member
iTrader: (3)
Join Date: Apr 2008
Location: uniontown PA
Posts: 873
yea but there are no other installers around here i know of and i was going to take everything to bestbuy to get it installed but isee thay dont do it all the way either see the problem now days is noone cares about whos shit there working on all thay wanna do is get it done and make money lol i can do it my self but i work almost everyday all day so i dont have to much daylite time iv been messing around with car audio for over 10 years (maby not even close to some exp others have) and the fact of breaking it. i think im more worried about the other guys breaking it then i am becouse again like i said thay dont care its not theres lol but now that im thinking about it i might just do it my self owell
 
  #30  
Old 02-15-2009, 08:26 PM
Member
Join Date: Nov 2007
Location: Wilton, CT
Posts: 578
Originally Posted by MorningZ View Post
I purchased a the Scosche kit a month or two ago and the bottom was just fine (no problems like the original poster)

My problem with the kit was the top right corner which wouldn't stay flush with the dash...
Ditto for me, it's really bad.





Does reusing the factory clips really fix this? I'll give it a try, but that's not my only issue with this kit.

I, too, had the recirc sticker fall off on me within 2 minutes of pulling it out of the package. I pressed it back on as best I could, but I don't see it staying on there for very long without some extra glue or something.

Also, the sockets for the ac/defrost button and the passenger airbag light are too big. As is, the stock buttons would rattle around inside the faceplate, making an extremely annoying racket while driving. I "fixed" it by wrapping them in electrical tape so they fit more snugly.

And lastly, the kit didn't come with hardware that fit the screw holes in the front faceplate - the front 4 that hold the stereo on. So I reused the ones from the factory stereo . . . and whaddya know, they're too long, and they visibly dimpled out the plastic in the 4 corners surrounding the unit. You can see the top right bump in my pictures. They don't look terrible since they're all symmetrical & the same size, but seriously . . . wtf.

Overall, I'm NOT impressed with this thing. Probably gonna get a Metra.
 
  #31  
Old 03-18-2009, 08:50 PM
Member
Join Date: Nov 2007
Location: Wilton, CT
Posts: 578
Originally Posted by Daemione View Post
Does reusing the factory clips really fix this? I'll give it a try. . .
Finally had a chance to fool around with this thing some more the other day - swapped in one of the factory clips for that top right corner one. It's better, but still not a great at all.

Definitely going to get a Metra, this thing is a joke.
 
  #32  
Old 08-17-2009, 05:34 PM
grtpumpkin's Avatar
Member
iTrader: (6)
Join Date: Jun 2008
Location: inwood WV
Posts: 1,616
Does anyone know what Crutchfield sends with their stuff in the "install gear free" deal? I'm going to guess the poor fitting Scosche kit but it never hurts to ask...
 
  #33  
Old 08-17-2009, 05:42 PM
Member
Join Date: Apr 2007
Location: Normal, IL
Posts: 25
e-mail or call they should be willing to tell you.
 
  #34  
Old 08-17-2009, 07:34 PM
grtpumpkin's Avatar
Member
iTrader: (6)
Join Date: Jun 2008
Location: inwood WV
Posts: 1,616
I did some further digging and apparently Crutchfield is currently shipping Metra kits whooop!
 
  #35  
Old 08-17-2009, 09:23 PM
Member
Join Date: Aug 2008
Location: orlando, Florida
Posts: 25
I had a Merta kit got rid of it thought it looked cheap. I love the look of the Scosche kit. My sticker fell off when pulled out of bag 2. Just super glued it back on. Right corner out a little barely noticeable got 2 get OEM clips.
 
  #36  
Old 12-19-2009, 07:43 PM
New Member
Join Date: Nov 2009
Location: Houston, TX
Posts: 7
anyone got a Scosche kit from a new batch yet? wondering if these things are still issues...
 
  #37  
Old 01-27-2010, 10:02 AM
TurboManGT's Avatar
Member
iTrader: (4)
Join Date: Apr 2008
Location: Twin Cities
Posts: 1,421
Originally Posted by WannaBBurly View Post
anyone got a Scosche kit from a new batch yet? wondering if these things are still issues...
I just got a scosche kit last week and the posts are cut.
 
  #38  
Old 02-12-2010, 03:54 PM
Member
5 Year Member
iTrader: (6)
Join Date: Aug 2007
Location: Daly City, CA
Posts: 695
TurboManGt - Let us know if the corner is still a problem and if you swapped the clip/s out if you can take a picture of how it is with it. I might be getting the scosche kit also but want to see how replacing the clip will look like if I can live with it.
 
  #39  
Old 02-21-2011, 04:32 PM
Member
Join Date: Feb 2011
Location: Oahu, Hawaii
Posts: 44
does anyone know how these kits fit NOW?? has the company fixed these issues?
 
  #40  
Old 04-21-2011, 01:30 PM
Member
Join Date: Feb 2011
Location: St. Peters, Missouri
Posts: 24
Originally Posted by knicolas View Post
does anyone know how these kits fit NOW?? has the company fixed these issues?
+1 I'm curious.
 

Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.