Fit Interior & Exterior Illumination Threads discussing interior and exterior lighting modifications for the Fit/Jazz

High Powered h4 & h11

  #1  
Old 03-25-2012, 10:40 AM
krunk13's Avatar
Member
Thread Starter
Join Date: Mar 2012
Location: FORT LEONARD WOOD
Posts: 1,206
High Powered h4 & h11

Has anyone run into any issues running Piaa Plasma or any other high power 55w=130W bulb?
 
  #2  
Old 03-25-2012, 02:55 PM
Member
Join Date: Mar 2012
Location: San Francisco
Posts: 52
same question and do we need relay harness for the hid kit?
 
  #3  
Old 03-25-2012, 03:39 PM
krunk13's Avatar
Member
Thread Starter
Join Date: Mar 2012
Location: FORT LEONARD WOOD
Posts: 1,206
For HID's you dont need a relay harness but it is recommended to have one just incase something goes wrong with your factory harness or the hid ballasts.
 
  #4  
Old 03-25-2012, 04:34 PM
Member
Join Date: Mar 2012
Location: San Francisco
Posts: 52
well i know theres no need for a 35w but do i need one for a 55w? i dont want to spend $20 more if im not gonna use it
 
  #5  
Old 03-25-2012, 04:39 PM
krunk13's Avatar
Member
Thread Starter
Join Date: Mar 2012
Location: FORT LEONARD WOOD
Posts: 1,206
I would suggest just sticking with 35w. the 55w is only 10-15% brighter. IMO i dont think you really need it. I ran 35w on my Prelude and I could see EVERYTHING.
 
  #6  
Old 03-25-2012, 05:12 PM
Member
Join Date: Mar 2012
Location: San Francisco
Posts: 52
i have 35w 8k mod express on my celica and its not that bright.
 
  #7  
Old 03-25-2012, 05:22 PM
krunk13's Avatar
Member
Thread Starter
Join Date: Mar 2012
Location: FORT LEONARD WOOD
Posts: 1,206
Yeah cause you running 8K. OEM Lights from Lexus, Acura, BMW etc all run around 5300k because its the closest to sunlight. the farther you get from that number the dimmer the light will seem. You don't need Ultraviolet HIDs.
 
  #8  
Old 03-25-2012, 05:25 PM
krunk13's Avatar
Member
Thread Starter
Join Date: Mar 2012
Location: FORT LEONARD WOOD
Posts: 1,206
 
  #9  
Old 03-25-2012, 06:36 PM
Member
Join Date: Mar 2012
Location: San Francisco
Posts: 52
ah never thought of it that way thanks for the info and sorry for jacking your thread
 
  #10  
Old 03-27-2012, 02:06 PM
krunk13's Avatar
Member
Thread Starter
Join Date: Mar 2012
Location: FORT LEONARD WOOD
Posts: 1,206
So nobody knows?
 
  #11  
Old 03-27-2012, 03:28 PM
JamesBizzle's Avatar
Member
5 Year Member
iTrader: (13)
Join Date: Jul 2006
Location: Cerritos, Ca
Posts: 2,982
Originally Posted by krunk13 View Post
Has anyone run into any issues running Piaa Plasma or any other high power 55w=130W bulb?
I've ran Piaa Plasma Ion Yellow for my fog bulbs and haven't had any issues.
 
  #12  
Old 05-16-2012, 03:23 AM
GoFits's Avatar
Member
5 Year Member
Join Date: May 2006
Location: Chicago, IL
Posts: 653
Welll it's only drawing 55w which is the same and your standard headlight bulb....
 

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.