GD3 7 Speed Mode not working - Unofficial Honda FIT Forums

1st Generation (GD 01-08) The one that started it all! Generation specific talk and questions here!

GD3 7 Speed Mode not working

  #1  
Old 12-20-2018, 03:17 PM
GD3id's Avatar
New Member
Thread Starter
Join Date: Dec 2018
Location: Jakarta, Indonesia
Posts: 1
GD3 7 Speed Mode not working

Hi all..

I still have GD3 in garage in a good shape insideout. But this 6 months i had experieced that the 7 speed mode button not working as i pushed it. Sometimes i have to push harder than its started to work (the display came out)

But since last week i tried to use it again, it wont work. Push the button hard and genttle several times it wont appears in the lcd.

Is this have got to do with the socket or cables inside it? Or i have to replace the button set of it? I still can use kick down and shifted to S or L thooo, but if it can be fix that would be great

Need help guys maybe you have the same problem like mine but already solved it, please be kind to share it
 

Last edited by GD3id; 12-20-2018 at 03:24 PM.
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
rjd
3rd Generation (2015+)
2
04-14-2018 07:12 AM
fitowner10
Fit DIY: Repair & Maintenance
0
07-24-2016 01:31 AM
wackyflik
Fit DIY: Repair & Maintenance
0
07-05-2015 07:46 PM
victorgarage
Fit Engine Modifications, Motor Swaps, ECU Tuning
0
06-18-2014 10:12 AM
batman697
General Fit Talk
8
02-26-2008 07:49 PM


Thread Tools
Search this Thread
Quick Reply: GD3 7 Speed Mode not working


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.