1st Generation (GD 01-08) The one that started it all! Generation specific talk and questions here!

Horn not working

  #1  
Old 07-08-2019, 06:58 AM
Bend's Avatar
New Member
Thread Starter
Join Date: Apr 2019
Location: England
Posts: 19
Horn not working

Hello i have a gd1 uk honda jazz just fitted a mugen the horn has a dedicated pos and neg tab on the back still have the clock spring fitted the posative wire from the clock spring to one tab and tryed earting it to the bolt that hold in the wheel all fuses and relays are fine and the horn do work and so does the horn button any help would be great thanks
 
  #2  
Old 07-10-2019, 06:20 AM
Bend's Avatar
New Member
Thread Starter
Join Date: Apr 2019
Location: England
Posts: 19
No worries all sorted just had to change the earthing point on the horn button
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
bigbaby
2nd Generation (GE 08-13)
8
11-13-2018 08:57 AM
dbcmaster
General Fit Talk
3
05-16-2017 07:34 AM
AndrewLOL
2nd Generation (GE 08-13)
1
01-29-2011 10:37 AM
gummyrabbit
General Fit Talk
7
11-23-2007 03:30 PM
benfal2001
General Fit Talk
0
12-09-2006 01:45 AM


Thread Tools
Search this Thread
Quick Reply: Horn not working


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.