1st Generation (GD 01-08) The one that started it all! Generation specific talk and questions here!

is there something wrong with my fit??

  #1  
Old 11-19-2008, 09:37 AM
Member
5 Year Member
Thread Starter
Join Date: Mar 2008
Location: Camden, NJ
Posts: 35
is there something wrong with my fit??

i ahve a 08 fit in sport auto with only 8900 miles on it. however the yellow warning light just came on with my oil still at 50% life cycle. I have the scan gauge and no codes were found as well.. i'm scratching my head b/c according to my user manual the next check up is at 15000. is there something wrong or should i get take it to the dealer?? . also the car drives just fine much tx,
 
  #2  
Old 11-19-2008, 10:06 AM
TurboManGT's Avatar
Member
iTrader: (4)
Join Date: Apr 2008
Location: Twin Cities
Posts: 1,421
Did you check your oil?
 
  #3  
Old 11-19-2008, 10:44 AM
Member
5 Year Member
Thread Starter
Join Date: Mar 2008
Location: Camden, NJ
Posts: 35
it was done at the dealer. meter read 50% life remaining
 
  #4  
Old 11-19-2008, 11:32 AM
Rod2Rice's Avatar
Member
5 Year Member
iTrader: (11)
Join Date: Apr 2008
Location: NY
Posts: 907
So you had an oil change done at the dealer? did they reset the maintenance minder?
 
  #5  
Old 11-19-2008, 11:46 AM
~murr~'s Avatar
Member
Join Date: Sep 2007
Location: Bham, AL
Posts: 93
i heard if you don't reset the maintence light, than a yellow light comes on randomly
 
  #6  
Old 11-19-2008, 12:23 PM
Member
5 Year Member
Thread Starter
Join Date: Mar 2008
Location: Camden, NJ
Posts: 35
the oil change was done about 2000 miles ago and the yellow light has been off since. what bothers me is the no code reading from scan gauge.. i'm thinking about just checking oil in a bit and if that's okay then i'm taking it to the dealership the 1st tuneup is at 12000k miles right??
 
  #7  
Old 11-19-2008, 03:03 PM
Rod2Rice's Avatar
Member
5 Year Member
iTrader: (11)
Join Date: Apr 2008
Location: NY
Posts: 907
I am sure the owners manual has the info on service intervals, and why the light might come on at certain miles. Exactly which light is on? Are you sure its not the TPMS light now that the temps are getting cold and pressure drops in the tires?
 

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.