2nd Generation (GE 08-13) 2nd Generation specific talk and questions here.

Stereo Firmware

  #1  
Old 02-12-2010, 11:22 AM
New Member
Thread Starter
Join Date: Nov 2008
Location: Herndon, VA
Posts: 2
Stereo Firmware

Is there a way to upgrade the firmware on the stereo system on my '09 Sport with Navi? I know I can update the maps but the stereo does not recognize iPhone properly. Is this possible via DIY or through the dealership?
 
  #2  
Old 02-12-2010, 12:49 PM
Member
5 Year Member
Join Date: Feb 2009
Location: NYC
Posts: 285
I was in touch with Honda about a year ago, hoping to have the firmware updated to improve USB functionality, and they wouldn't budge. I think that your best bet is to research the various aftermarket options out there and then replace the stock HU. I've got my eye on the Alpine CDA-101, but I don't want to try installing it until the weather warms up, when the plastic parts I'll have to remove will be less brittle.
 
  #3  
Old 02-12-2010, 01:48 PM
Member
iTrader: (1)
Join Date: Aug 2009
Location: NY
Posts: 363
There is a way to update the firmware, but there are no firmware updates to my knowledge.

My system works fine with my iphone, aside from the message that pops up asking to go into airplane mode, but ignore it and it works fine. This seems to happen in a lot of stereo systems though (my friend's 2010 VW GTI for example).
 
  #4  
Old 02-12-2010, 05:37 PM
Member
Join Date: Dec 2009
Location: Rochester, NY
Posts: 86
Might be nice to let you scroll folders/songs from end to beginning (99 right to 01) rather than having to go all the f*king way back. The person who designed this should be shot. Or fired. Either way.
 
  #5  
Old 02-12-2010, 05:46 PM
Member
5 Year Member
Join Date: Feb 2009
Location: NYC
Posts: 285
Originally Posted by Bowkr View Post
Might be nice to let you scroll folders/songs from end to beginning (99 right to 01) rather than having to go all the f*king way back. The person who designed this should be shot. Or fired. Either way.
Yes, I mentioned this to Honda in my rather lengthy and very polite letter. The guy who called me to follow up on it said--very politely--that I was out of luck. You can see the letter if you do a search on the subject--I posted it about this time last year.

This and other interface issues, along with the poor sound quality that's apparently due to the HU and not so much the speakers, leads me to think I'll just have to get rid of the thing.

A heads-up for potential buyers of the Fit Sport: it's a great car, but the sound system is a big disappointment for many of us.
 
  #6  
Old 02-15-2010, 11:01 AM
Member
5 Year Member
Join Date: Jun 2009
Location: Philadelphia, PA
Posts: 154
The scrolling issue is a huge pain in the a** and podcasts aren't an option directly, but other than that I don't have any issues with the sound system. My iPhone works fine.
 
  #7  
Old 06-22-2010, 11:15 AM
New Member
Join Date: May 2009
Location: Chicago, IL
Posts: 1
Unforunately, the new iPhone iOS4 won't work at all with the 2009 Fit stereo. I get an "Unsupported" message from the Fit. :-(

Update: After restarting the phone by holding down the Power AND Home button for 10 seconds the Fit to Phone USB connection works great! I believe this is called a "hard restart" as the normal "soft restart" did nothing to help my problem originally.
 

Last edited by silverwolfe; 06-22-2010 at 01:43 PM. Reason: Update
  #8  
Old 06-22-2010, 12:28 PM
Member
iTrader: (1)
Join Date: Jun 2009
Location: san diego, ca
Posts: 718
Originally Posted by Eugene.Atget View Post
Yes, I mentioned this to Honda in my rather lengthy and very polite letter. The guy who called me to follow up on it said--very politely--that I was out of luck. You can see the letter if you do a search on the subject--I posted it about this time last year.

This and other interface issues, along with the poor sound quality that's apparently due to the HU and not so much the speakers, leads me to think I'll just have to get rid of the thing.

A heads-up for potential buyers of the Fit Sport: it's a great car, but the sound system is a big disappointment for many of us.



idk what fit you got but my ge's stock speakers sound great hahah the only "electronic" upgrade i have dont so far is just a simple grounding kit so maybe they just messed up on the navi unit? i have non nav. btw
 
  #9  
Old 06-22-2010, 01:07 PM
Fit4Spl's Avatar
Member
5 Year Member
iTrader: (1)
Join Date: Apr 2010
Location: Orlando, FL
Posts: 651
There are plenty of options out there aftermarket wise to do what you want with an iPhone. Alpine has a ton of products that I am sure you could find something to suit your needs. Alpine Electronics of America, Inc. I have used Alpine for years and the quality is bar none some of the best on the market.

As a side note, the factory speakers are terrible, maybe its because I am an audio nut that I feel that way but if you could hear the difference between a stock Fit sound system playing a song such as YouTube - Pendulum 'Watercolour' and then hear something that was upgraded to a New Headunit and speakers only you would be amazed as the difference.
 
  #10  
Old 06-22-2010, 01:36 PM
Join Date: Aug 2009
Location: bay area, cali
Posts: 692
FWIW, you can search and select music through your jailbroken iphone with a tool called NoAccessorySplash when plugged in through the dock port. i was seeking this mainly for my passengers who can scroll through my actual phone and choose what they want to listen to. it also works well for using streaming radio like pandora since you have access to the pause button in ipod.app. (you pause ipod.app and then load pandora, last.fm, etc.)

i have replaced the stock head unit w/ my alpine but it works the same way on both and all stereos that plug in through the dock port.
 
  #11  
Old 06-23-2010, 09:33 AM
Member
5 Year Member
Join Date: May 2009
Location: Shreveport, LA
Posts: 225
Originally Posted by silverwolfe View Post
Unforunately, the new iPhone iOS4 won't work at all with the 2009 Fit stereo. I get an "Unsupported" message from the Fit. :-(

Update: After restarting the phone by holding down the Power AND Home button for 10 seconds the Fit to Phone USB connection works great! I believe this is called a "hard restart" as the normal "soft restart" did nothing to help my problem originally.
I should've done I search. I started a new thread, then saw the link somewhere to the apple support forum on the issue. Mine works fine now as well!
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
alile
General Fit Talk
0
09-04-2015 02:41 PM
wvucyclist
3rd Generation GK Specific Fit I.C.E. Sub-Forum
0
05-04-2014 09:35 PM
deevergote
2nd Gen GE8 Specific Fit Interior Modifications Sub-Forum
6
06-10-2012 10:41 AM
Cutstain
2nd Gen GE8 Specific Fit Interior Modifications Sub-Forum
4
10-05-2010 11:34 PM
john21031
2nd Generation (GE 08-13)
2
12-26-2009 02:18 PM


Thread Tools
Search this Thread
Quick Reply: Stereo Firmware


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.