3rd Generation (2015+) Say hello to the newest member of the Fit family. 3rd Generation specific talk and questions here.

radio flashes and turns off..

  #1  
Old 11-28-2018, 07:47 PM
Member
Thread Starter
Join Date: Apr 2015
Location: Southern Illinois
Posts: 196
radio flashes and turns off..

First problem with the Fit. Right at 100,000 miles too.

Did a 700 mile trip. At about 100 miles the radio turned off. Looked down and it was black. Lasted maybe 2 seconds tops. Turned itself back on, and acted like I just started the car (warning screen, etc). Nice smooth interstate.

At about mile 600 it did it again. I watched it do it this time. The on/off button flashed a couple times and it went black. Then back through the start up programming. Nothing else in the dash or operation of the vehicle stumbled. Nice smooth interstate.

This is the only thread I've found, so I'm guessing I might be in uncharted regions here. Maybe, it was blamed on Pandora. Thoughts? Happen to anyone else?

https://www.fitfreak.net/forums/3rd-...io-issues.html
 

Last edited by robs; 11-28-2018 at 07:51 PM.
  #2  
Old 11-28-2018, 08:20 PM
ieandro's Avatar
Member
Join Date: Jun 2018
Location: NJ
Posts: 107
I'm fresh from just getting a brand new unit installed from the dealership. My issue was from having intermittent sound issues that was from the head unit itself unlike your issue. Dealer couldn't replicate the problem, but went ahead and replaced the entire unit. Searches from different model forums (CR-V, Civic, Accord) netted some known TSB's, but apparently none for the Fit itself. May not be an official problem from Honda (yet), but their replacement of my radio (even though nothing was wrong at the time it came in) makes me wonder if something is on the horizon for official head unit issues.

No Sound Issue

By the way, I only have 6K so i'm still under warranty, but hopefully enough come forward that Honda does right by its customers.

Good luck.
 
  #3  
Old 12-02-2018, 07:03 PM
Uncle Gary's Avatar
Member
5 Year Member
Join Date: Apr 2009
Location: Upstate New York
Posts: 2,355
My head unit did a similar thing last year. I was driving on a trip when the screen went black and the head unit wouldnít respond. Stopping and restarting the car didnít do anything, but about fifteen minutes later the head unit rebooted all by itself, warning screen and all. I filmed it with my phone for proof, but itís never happened again.
 
  #4  
Old 12-03-2018, 12:11 AM
Join Date: Aug 2015
Location: San Diego
Posts: 31
My radio (the EX unit) did this a couple times when the car was new, but it stopped on its own.

I'd like to replace it as the sound is crap, but I don't want to lose lanewatch.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
jy1129
2nd Generation (GE 08-13)
15
01-28-2018 07:48 PM
Tranas
Fit Interior & Exterior Illumination
8
12-16-2017 02:40 PM
dhk
General Fit Talk
12
06-04-2015 07:19 AM
evo911
1st Generation (GD 01-08)
2
10-01-2013 03:36 AM
jhauschildt08
Fit DIY: Repair & Maintenance
9
03-08-2013 11:22 AM


Thread Tools
Search this Thread
Quick Reply: radio flashes and turns off..


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.