Installing PROTOTYPE engine mounts from Innovative - Unofficial Honda FIT Forums

Go Back  Unofficial Honda FIT Forums > Fit Modifications > Fit Engine Modifications, Motor Swaps, ECU Tuning
Reload this Page >

Installing PROTOTYPE engine mounts from Innovative

Fit Engine Modifications, Motor Swaps, ECU Tuning Reference Library for Engine Modifications, Swaps and Tuning

Installing PROTOTYPE engine mounts from Innovative

  #1  
Old 04-29-2007, 02:02 AM
leonine's Avatar
Member
5 Year Member
Thread Starter
Join Date: Jun 2006
Location: The Twilight Zone
Posts: 1,710
Installing PROTOTYPE engine mounts from Innovative

Disclaimer: The following is provided as a GUIDE ONLY, and neither myself, nor Fitfreak.net take any responsibility for the outcome of someone else doing the following. You follow these steps at your own risk! If you are not extremely comfortable doing this get the help of a friend or 2 OR have a mechanic do it!

Thanks to GETTINAFIT for his much needed help during installation! Thanks to Innovative for hooking me up! and thanks to 03DSMRDX for helping me find Innovative!

It took me and gettinafit about 4 hours to install with air tools. We had to do some grinding to get the A/T tranny mount in but these are prototypes and Innovative designed them without having a car in their shop. Overall i'd say they did an AMAZING job. The majority of the install was done with a full-size jack (shown below). However we did use an engine stand (because it was available) at one point. I think a jack could be used for the whole thing but depending on how high you raise the vehicle the jack you are using might not give you enough clearance when raising the engine.

shall we begin!

First raise the vehicle on jackstands. Allow room for working under the car but too high and you will not be able to raise the engine from underneath. You will need a FULL SIZE jack similar to the one showed below (among other things).


Then remove both front wheels. Lower the jack and place some wood on top of the jack. Place it under the engine close to the back as shown below.



Then raise the jack up until it moves the engine up an inch or so.


Remove the following(pics not included):
- air intake box
- battery
- battery tray

Now that we have got that mundane stuff out of the way let us take a look at the engine. Keep in mind that throughout this installation we were frequently jacking the engine up and down (within reason) to get the mounts out and in.

The picture following is a view of the A/T tranny mount. Looking at the arrows do the following:

- remove the 4 bolts labeled by the green arrows starting with the 1 that the wrench is on. This is the bolt that goes through the middle of the tranny mount. Take note of the red arrow. This is pointing to a plastic shroud that will need to be removed in order to get the bolt out. It is small and is easy to pry off. Just one clip. Then remove the 2 nuts and 1 bolt labeled with the blue arrows.


This pick below shows the tranny mount after removing the 3 bolts holding the mount to the frame. You will need a pry bar also throughout this installation. Use the prybar to pry the old tranny mount out of the aluminum housing.



Here's a pic of the old and new tranny mount side-by-side. The red part that is highlited was obstructing installation. We made it work (as you will see) but the production version will need to be modified. I notified Innovative and i am sure they will look into it.


Another pic of the tranny mount.


Old mount and aluminum bracket (that we will reuse)


Here is a pic of the engine with the entire tranny mount and housing removed.


Now we are not going to put the tranny mount back on yet. We need as much clearance as we can get for the rear engine mount. Raise the engine high up being careful about clearance and any engine hoses/clamps/etc...

Now lets take a look under the car.


Remove the bolts marked with the green arrows in the pic above and remove the black mount bracket.



Another pic of the rear from a different angle above. the bolt going through the center of the mount should be removed last.



Now raise the engine up from the rear as shown above so you have more clearance to get to the bolt going through the mount.



After you have removed the black mount cover you will need to remove 2 more bolts. 1 is shown by the green arrow. the other is not seen directly from this pic. After you remove them take out the rear mount.



The pic above shows the new rear mount in its mounting position. green arrows indicate where the bolts go. Reinstall all hardware and mounting bracket.

Now that the rear is on we can put the tranny mount back in. Install the 3 tranny mount bolts but not the center bolt going thru the bushing. Then reinstall the aluminum housing as show. Use a rubber mallet or pry bar to get the housing in place while raising/lowering the engine for proper clearance. This took a little time to get in but it will go.


Now thread the center bolt thru the bushing. Again you will have to raise/lower the engine slightly to get it thru. Then tighten everything up.


Now lets do the passenger side mount shall we. Below shows 2 pics with the stock mount. Remove all bolts/nuts marked with the green arrows.

The red arrow above points to the bolt that you will remove but not reuse.

Above shows the other 2 nuts that should be removed. 1 is visible from the top and 1 is visible from underneath through the wheel well.


Remove the 2 bolts holding the A/C line so you have a little more clearance to remove the mount.

Below are pics of the OEM and new mounts side-by-side.


Note the metal spike attached to the OEM mount. I had to get a 10x40 1.25 bolt and nut to replace it.



Now install the new mount and reuse the top part of the OEM mount or the stock bolts will not fit. Again raise/lower the engine and use a pry bar to get the bolts threaded.



Above shows the new mount in place. Below shows the other side.



Make sure everything is tightened up. I also used blue threadlock on some of the bolts.

NOW YOU ARE DONE Go out and put that power to the ground.

RESULTS:

- the construction of the mounts is TOP NOTCH! They are fantastic. All OEM hardware was re-used in installation.

- Initial startup has noticably more vibrations. It took a minute for the car to fully warm up but once it did vibrations reduced significanlty.

- Yes it does vibrate some and you hear much more of the engine but it is not as bad as i thought. I drove the car home 50 miles and on the highway vibration was nominal.

- Cabin vibration is suprisingly nominal. My radar detector was vibrating but it did that before. Fixed that when i got home. The Fit interior has it's quirks with noise. The mounts have made some of those noises more dominant. But that is to be expected. But i was expecting worse and was pleasantly surprised.

*remember i have a 75A rear mount. The 2 sides are 60A. I would say that a 60A rear mount would reduce the vibrations even more.

Now for performance:

- Throttle response is 100% better. Accelleration is smooth and lag between shifts has been noticably reduced.

- S mode is now more like a true manual. By that i mean that upshifts and especially downshifts are instantanious. Before if i downshifted it would pause at least a second after the tap for it to kick in. Now it is tap and GO!

Enjoy Fitfreaks.
 

Last edited by leonine; 04-29-2007 at 08:59 AM.
  #2  
Old 04-29-2007, 11:06 AM
Member
5 Year Member
Join Date: Apr 2006
Location: New YOrk
Posts: 1,202
Nice Write up!! Maybe I should become an Arm model? hehehe j/k

But yeah it was an easy install, but without the extra 30-45 minutes of customization, that would have been nicer!

I"m sure that innovative will make it right for the release kit!
 
  #3  
Old 04-29-2007, 11:12 AM
leonine's Avatar
Member
5 Year Member
Thread Starter
Join Date: Jun 2006
Location: The Twilight Zone
Posts: 1,710
Yeah your arm has been in more DIY's on this forum than i can remember. Great job bro!
 
  #4  
Old 04-29-2007, 12:08 PM
koolkevin1107's Avatar
Member
5 Year Member
iTrader: (22)
Join Date: Jun 2006
Location: La Crescenta, CA
Posts: 2,992
excellent writeup. Only thing i dont see is the area where u had 2 notch the body for the mount to fit. It says the "red part highlighted" but i don't see it. None the less, great writeup. I'd love 2 get the engine mounts (all 60a of course) cuz i did wish my AT would shift a little faster. How much did the kit run anyways.
 
  #5  
Old 04-29-2007, 06:19 PM
leonine's Avatar
Member
5 Year Member
Thread Starter
Join Date: Jun 2006
Location: The Twilight Zone
Posts: 1,710
Originally Posted by koolkevin1107 View Post
excellent writeup. Only thing i dont see is the area where u had 2 notch the body for the mount to fit. It says the "red part highlighted" but i don't see it. None the less, great writeup. I'd love 2 get the engine mounts (all 60a of course) cuz i did wish my AT would shift a little faster. How much did the kit run anyways.
n

The pic above shows it. Look where the mount meets the frame. Not a big deal.

I just got a response from Innovative. The received the pics i sent and will be correcting the problem with the tranny mount. Then they will send me one in raw form to check for fitment.

As for how much only the cost of OEM mounts and shipping to them. Being my car is a daily driver i did not want it to off road so i bought them and shipped them out. They designed the new ones and sent them to me.

I would think these mounts will probably retail in the same price range as their others. I'm just guessing so dont quote me but maybe 250 or so. That would be for a set of 60A mounts with red urethane and a black powder coat. Custom paint and colored urethane are additional accordin to there website. They are also coming out with a billet version i think. I will ask them and see if i can get a definitive answer.

P.S. The red arrow you are referring to is pointing to a plastic piece not seen in the picture. It needs to be removed in order to get the tranny bolt out.

Peace.
 

Last edited by leonine; 04-29-2007 at 06:22 PM.
  #6  
Old 05-01-2007, 09:02 AM
Wave's Avatar
Member
5 Year Member
iTrader: (1)
Join Date: May 2006
Location: Long Island, New York
Posts: 1,093
Very cool Leo...

when can we start ordering? Got a link?

Looks like I get to dump some more $$$ into my car!
 

Last edited by Wave; 05-01-2007 at 09:05 AM.
  #7  
Old 05-01-2007, 10:52 AM
leonine's Avatar
Member
5 Year Member
Thread Starter
Join Date: Jun 2006
Location: The Twilight Zone
Posts: 1,710
Originally Posted by Wave View Post
Very cool Leo...

when can we start ordering? Got a link?

Looks like I get to dump some more $$$ into my car!
Innovative Mounts
(714) 524-5246 - if the voicemail picks up and asks you for an extension press the number 1 and it should connect you to sales.

They are working on redesigning the tranny mount so it will fit in without any custom work. They are going to send me a mount to check for fitment so it could be another 3 to 4 weeks.

But i bet if people interested call them it might speed up the process
 

Last edited by leonine; 05-02-2007 at 11:24 AM.
  #8  
Old 05-01-2007, 10:53 AM
leonine's Avatar
Member
5 Year Member
Thread Starter
Join Date: Jun 2006
Location: The Twilight Zone
Posts: 1,710
Here's a link to their website:

Welcome to Innovative Mounts
 
  #9  
Old 05-02-2007, 11:23 AM
leonine's Avatar
Member
5 Year Member
Thread Starter
Join Date: Jun 2006
Location: The Twilight Zone
Posts: 1,710
Spoke 2 innovative and they said the kit will be between $279 and $299 for all 60A mounts, black powdercoated, and red urethane. That is what they will have in stock. Custom paint or urethane will take additional time and cost somewhere around $30.
 
  #10  
Old 05-16-2007, 02:30 AM
quangalang's Avatar
Member
Join Date: Jul 2006
Location: california
Posts: 667
those mounts would be more effective if you had a manual tranny, save your money if you have an auto unless you are making loads of power.
 
  #11  
Old 05-16-2007, 10:51 AM
leonine's Avatar
Member
5 Year Member
Thread Starter
Join Date: Jun 2006
Location: The Twilight Zone
Posts: 1,710
Every bolt on performance part will make more power with a manual. But the fact is that there are probable 3 or 4 times more autos out there than manuals and i would like the most power i can get. They are worth the money IMO plus there are several boost kits coming out soon and these mounts would make a big difference.
 
  #12  
Old 05-18-2007, 07:36 PM
Hondady's Avatar
Member
Join Date: Sep 2006
Location: G-Ville, Pa U.S.A
Posts: 291
Originally Posted by leonine View Post
Every bolt on performance part will make more power with a manual. But the fact is that there are probable 3 or 4 times more autos out there than manuals and i would like the most power i can get. They are worth the money IMO plus there are several boost kits coming out soon and these mounts would make a big difference.
You are absolutley right. Just because your driving an auto doesn't mean it won't make a difference. Plus when your in S mode it's like driving a manual anyway. Plus we have first hand testing on an auto to prove that it does make a difference. These will be nice when I purchase my JR charger! Which I can't wait for. Good right up by the way!
 
  #13  
Old 05-18-2007, 10:53 PM
leonine's Avatar
Member
5 Year Member
Thread Starter
Join Date: Jun 2006
Location: The Twilight Zone
Posts: 1,710
ohh i forgot to mention i have ZERO wheel hop now. used to have allot when cornering and in the wet weather. All gone now.
 
  #14  
Old 06-22-2007, 09:56 PM
justinfox's Avatar
Member
Join Date: Mar 2007
Location: Sydney Australia
Posts: 61
I can't be 100% but can any of you guys confirm that these mounts would fit on Honda Jazz/Fits sold outside of the USA? I'd assume that engine mounts would be the same, but I could be assuming wrong.
 
  #15  
Old 09-10-2007, 10:22 AM
Wave's Avatar
Member
5 Year Member
iTrader: (1)
Join Date: May 2006
Location: Long Island, New York
Posts: 1,093
Thumbs up Life Savers!!!!!!

Just wanted to give special thanks to all the guys I've dealt with at Innovative Mounts to rush me a complete set of mounts for my Fit A/T.

I went with 75A bushings all around and Candy Apple Blue powdercoated steel mounts. It vibrates a tad bit more than stock which some people may/may not like. Go with the red bushings if you want comfort.

First class product all around!

Thanks Once Again to INNOVATIVE MOUNTS.
 
  #16  
Old 09-10-2007, 10:28 AM
03DSM-RSX's Avatar
Frequent FitFreak Poster
Join Date: May 2006
Location: Houston
Posts: 619
wow 75A, pretty stiff! i wish i had the 75A rear mount
 
  #17  
Old 09-10-2007, 10:31 AM
Wave's Avatar
Member
5 Year Member
iTrader: (1)
Join Date: May 2006
Location: Long Island, New York
Posts: 1,093
Originally Posted by 03DSM-RSX View Post
wow 75A, pretty stiff! i wish i had the 75A rear mount
yeah, definitely vibrates the dashboard but I don't mind.

Oh and thanks to "gettinafit" for the install!
 
  #18  
Old 09-10-2007, 10:47 AM
03DSM-RSX's Avatar
Frequent FitFreak Poster
Join Date: May 2006
Location: Houston
Posts: 619
so how does driving feel? shifts, WOT run, etc. write a review for everyone

word of caution to potential buyers, Innovative is having issues with the billet mounts on all cars. but the steel version has been flawless. so get the steel version for now. They are currently trying to resolve the issue.
 
  #19  
Old 09-10-2007, 11:35 AM
Wave's Avatar
Member
5 Year Member
iTrader: (1)
Join Date: May 2006
Location: Long Island, New York
Posts: 1,093
Originally Posted by 03DSM-RSX View Post
so how does driving feel? shifts, WOT run, etc. write a review for everyone

word of caution to potential buyers, Innovative is having issues with the billet mounts on all cars. but the steel version has been flawless. so get the steel version for now. They are currently trying to resolve the issue.
Driving? With my 75A bushings it's nice and smooth while cruising at highway speeds. When you're at idle there is more vibration felt in the cabin. Response when you stomp on the gas seems better as well. Once again if you want to remain with stock comfort and feel then you want the RED BUSHINGS.

WOT is pretty nutz because it seems like the engine "got louder" - but in a good way, no stealth mode here but I suspect it's because of my H-Fit Supa Sucka intake. I can't explain it but I can really hear my engine working now and it seems "more alive" it's very cool!

I'm going on a road trip this weekend down to Virginia so I'll post more thoughts afterwards but so far I'm very happy with my Innovative mounts.

Didn't hear about the issue with the Billet mounts - whats the deal with that? I have steel and they are damn solid so I'm not concerned at all with mine.
 
  #20  
Old 09-10-2007, 05:52 PM
03DSM-RSX's Avatar
Frequent FitFreak Poster
Join Date: May 2006
Location: Houston
Posts: 619
it seems louder b/c engine noise and exhaust are resonated thru the cabin from stiffer mounts.
 

Thread Tools
Search this Thread
Quick Reply: Installing PROTOTYPE engine mounts from Innovative


Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.