3rd Generation (2015+) Say hello to the newest member of the Fit family. 3rd Generation specific talk and questions here.

Back-Up Camera Black Screen

  #1  
Old 02-28-2019, 05:34 PM
New Member
Thread Starter
Join Date: Mar 2016
Location: Boston, MA
Posts: 7
Back-Up Camera Black Screen

Anyone experience the "black screen" on their back-up camera? When I shift into reverse, I get the guidelines and the buttons to change the view, but the screen is (otherwise) completely black. And, I'm not talking maybe the lens is dirty...I'm talking nothing there.

I poked around online and saw some Civic and Accord owners running into this, but many of them solved it by doing a system re-boot (holding down the power button), but that seems to only work on 2016+ models with a slightly different user interface. Mine is a 2015 EX with about 50k miles.

I'm hoping there is some quick and easy fix rather than going to the dealer and getting charged hundreds of dollars to figure it out. I should note that I discovered this after a brake job and oil change and Midas, but they insist they didn't disconnect the battery or do anything that would cause this...they say I need to go to a dealer to get it diagnosed. Ugh.
 
  #2  
Old 02-28-2019, 08:31 PM
Member
5 Year Member
Join Date: Sep 2010
Location: milwaukee, wi
Posts: 568
First thing I'd do is contact Honda corporate. Ask them if it's a known issue and what assistance they might offer. Never hurts to ask, and I prefer going through corporate first, because dealers are not terribly enthused by potential warranty service and try to rebuff you whenever possible.

The backup camera operates through the CANBUS system. Doubtful that Midas could have done anything to mess with the CANBUS. I suppose there's an outside chance the cable got disconnected from the main unit, and that might reproduce the symptoms you're having, but I really suspect a software issue more than anything mechanical.
 
  #3  
Old 03-01-2019, 03:04 PM
New Member
Thread Starter
Join Date: Mar 2016
Location: Boston, MA
Posts: 7
Great advice...thanks! The Midas guys seemed pretty honest and confident that this wasn't tied to anything they did. I chatted with Honda Corporate and they say there are no known issues or associated campaigns on this. Since I'm really not interested in a separate trip to the dealer for this, I'll just wait until my next scheduled service. Maybe then, they will be more likely to do some sort of de-glitching free of charge.
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Arthur75
Fit Freak Newbie / FAQs
2
02-22-2017 11:54 AM
ncoflin
3rd Generation (2015+)
1
11-08-2016 08:13 AM
karimmusa8
Fit Suspension & Brake Modifications
0
05-13-2010 01:54 PM


Thread Tools
Search this Thread
Quick Reply: Back-Up Camera Black Screen


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.