3rd Generation (2015+) Say hello to the newest member of the Fit family. 3rd Generation specific talk and questions here.

2015 Honda Fit Fuel Gauge Display Failure

  #21  
Old 10-26-2018, 07:23 PM
Member
Join Date: May 2015
Location: Madison TN
Posts: 661
Talking Polution sollution?

Originally Posted by 2015FITEX View Post
+1

Im getting a horse next time.
And your solution to THAT pollution?
 
  #22  
Old 10-27-2018, 09:47 AM
Member
5 Year Member
Join Date: May 2012
Location: Boston, MA
Posts: 1,268
Stinks to hear this. More complexity = more stuff to go wrong. What exactly was wrong with having a fuel gauge?

Am I correct that little display is used in some other Honda products?

Word on the internets is, Honda is going to shift Fit production back to Japan. The new tripartite trade pact mandates at least a certain percent of US parts to be tariff free, reducing the appeal of Mexican suppliers. I support this both because it'll be good for the American economy (out sourcing has got a bit out of hand) but also it should improve the quality for the Fit
 
  #23  
Old 10-27-2018, 03:17 PM
Member
Join Date: May 2015
Location: Madison TN
Posts: 661
Originally Posted by fujisawa View Post
Stinks to hear this. More complexity = more stuff to go wrong. What exactly was wrong with having a fuel gauge?

Am I correct that little display is used in some other Honda products?

Word on the internets is, Honda is going to shift Fit production back to Japan. The new tripartite trade pact mandates at least a certain percent of US parts to be tariff free, reducing the appeal of Mexican suppliers. I support this both because it'll be good for the American economy (out sourcing has got a bit out of hand) but also it should improve the quality for the Fit
Contrary to most of my life experience, I must be luckier than most 2015 Fit owners. I'm not OCD (fortunately), but few real problems (clutch switch). Then again, I have less than 10k on the EX.
 
  #24  
Old 10-27-2018, 09:50 PM
Member
Join Date: Oct 2015
Location: Portland Or
Posts: 1,367
Common problem on a lot of brands the last few years, often can be fixed by removing the cluster form the car and carefully desoldering all the solder joints on the circuit boards. (Cheap green led free solder cracks and gets bad joints easy.) Regular lead free solder from an electronics shop and a decent small iron do the trick. .
 
  #25  
Old 11-12-2018, 09:10 AM
New Member
Join Date: Nov 2018
Location: Leander
Posts: 3
The display on my 2015 FIT started wigging out last winter when the temp got around the freezing mark. One the car warmed up above that point it worked fine. This year, I noticed that the display craps out around 47 deg F so it appears to be degrading over time. Any idea what the repair cost would be?
 
  #26  
Old 11-27-2018, 10:39 PM
New Member
Join Date: Nov 2018
Location: Conway, SC
Posts: 1
Just commenting to say same issue on my 2015 Honda LX. I live in the South where it will get up to 100+ in summer consistently but the issue has occurred now for the past two winters, usually when temperatures drop into the 50-60s. The screen will start off as lit, but blank, as in the one pictured above, then as I drive and the vehicle begins to warm up it will first show a scrambled display that will flicker on and off, until ultimately going back to normal after I drive roughly five minutes or so (temperature dependent, colder days can take much longer; it was 31 last night and took forever and a half for the display to come back). All of the gauges are still reading correctly while this is occurring, it's just an issue with the display itself not working properly.

The Fit is out of warranty but it was noted by the dealer before the warranty was up, they asked to have the car left overnight so they can duplicate it, but I haven't had a good chance to do so. That said, they said because the issue was reported before the warranty was up that they will service it in the future, so if I learn anything else (probably won't) I'll try to update this.
 
  #27  
Old 11-27-2018, 10:47 PM
New Member
Join Date: Nov 2018
Location: Leander
Posts: 3
Unfortunately I'm past the warranty period. Looked at some youtube videos on replacing the instrument cluster and it doesn't look very difficult. Just a few screws. The part however is ~ $500. Ouch.
 
  #28  
Old 11-28-2018, 12:05 AM
Member
Join Date: May 2015
Location: Vancouver , BC
Posts: 135
IF the "parts" fix it........what is actually "gone" if this display dies?...distance to empty is on the 7" display..maintenance minder ?....disposable........ what else is lost ?

thanks CRTRUE for the update!!
 
  #29  
Old 11-28-2018, 09:03 AM
New Member
Join Date: Nov 2018
Location: Leander
Posts: 3
Odometer indicator is gone as well. Hopefully that is stored elsewhere on a chip somewhere other than in the cluster itself, so that when you replace the cluster you get the mileage indicator number back.
 
  #30  
Old 12-28-2018, 10:51 AM
New Member
Join Date: Dec 2018
Location: daly city
Posts: 1
Honda fit

Hi.. I have the same problem.. we’re u able to solve problem?




Originally Posted by B.Dagle View Post
Hi All! I am having the same problem with my 2015 Honda fit LX. This seems to be a temperature related problem. It will go out as the interior of the car warms up. It will then come back on when it reaches full temperature. The Dealer wants to replace the information center at a significant cost to me! Has anyone gotten to the root cause of this problem? I'd very much like to fix it myself (have the skills). I also wonder how many people are having this problem? Is this a factory defect or a "One Of" just effecting just a few of us? Thank You!
 
  #31  
Old 01-05-2019, 02:06 AM
Member
Join Date: Jan 2019
Location: Milpitas, California
Posts: 28
Sucks to read so many owners have this display failure.
Has anyone wrote to America Honda Motor to reflect this problem even if its out of warranty? Maybe a group representation will get some attention for honda to address this.
 
  #32  
Old 01-10-2019, 05:55 PM
New Member
Join Date: Jan 2019
Location: LEDGEWOOD
Posts: 2
Originally Posted by PCee Iggy View Post
Hi.. I have the same problem.. we’re u able to solve problem?





Did anyone get back to you on the solution to this?
 
  #33  
Old 01-10-2019, 06:00 PM
New Member
Join Date: Jan 2019
Location: LEDGEWOOD
Posts: 2
This is in reply to blkfit2015 writing Honda. : I am going to write. That's a great idea. Maybe it will become a recall.
I actually have an extended service warranty that should cover this, but I have already left my car for 3 days and all they did was a factory data reset. It was good for 2 days( even in the cold warming up ) and then back to same old wigging out. I am going to bring it to another dealer, but I thought if anyone got to the bottom of the problem , I could share that info with the dealer.
 
  #34  
Old 01-11-2019, 02:28 PM
New Member
Join Date: Jan 2019
Location: Baltimore, MD USA
Posts: 1
Unhappy Same Problem Here - wonky fuel gauge display

Hi All,

Seems we're in same boat. I have a 2015 Fit EX and my display just started flaking out. I get the same gibberish and it does seem to be related to the cold. It's in the 20s and 30s (Fahrenheit) in Baltimore so I've been seeing this problem more and more. The gauge generally recovers when it heats up but it is an annoyance. I started noticing this at about 35k miles, I'm at 36.5 k now. It's sort of surprising how similar the profile is - seems like it occurs on 3rd Gen Fits, 30k+ miles, and associated with cold weather. Must be a parts or solder/assembly failure. It would be nice if Honda acknowledged this and made good for us owners. Not looking forward to paying $500 + labor on this.

Thanks,

-tom
 
  #35  
Old 01-13-2019, 07:43 AM
New Member
Join Date: Jan 2019
Location: Gaffney, SC
Posts: 1
same issues here ... 2016 fit with 20k miles

I live in SC and notice it started happening a few weeks ago. I took video and pics of it, now I have to make an appt with Honda. Wonderful. At least it's still under warranty.
 
  #36  
Old 02-02-2019, 11:12 AM
New Member
Join Date: Feb 2019
Location: Grand Rapids
Posts: 1
instrument cluster failure

need to report that i also had failure of instrument cluster at 30,000.00 miles ( under warranty) but at 3 years and 6 months ( out of warranty) This occurred in Minnesota winter
. after a call to Honda america they eventually decided to warranty this. I did not appreciate Honda America 's Monica, my "advocate", scolding me with language like" we make thousands of cars per year and some cars are going to fail because this is electronic so you will not get this covered"
REALLY? i did not buy into planned obsolescence of the instrument cluster
Dear Honda:..either warranty like it is a mechanical device are return to mechanical device so can read my speed and gas gauge. this is a safety issue
fortunately Monica's conversation was overruled. Good luck to those out of warranty!
 
  #37  
Old 02-03-2019, 08:52 AM
SFL_Fit's Avatar
Member
Join Date: Jul 2018
Location: Margate, Florida
Posts: 42
Easy fix If you got a buddy with a GK5 still under warranty 😉
 
  #38  
Old 04-04-2019, 11:53 AM
New Member
Join Date: Apr 2019
Location: Nellysford VA
Posts: 1
Another 2015 Fit Instrument Cluster Fail!

Our 2015 Fit LX started losing it's instrument cluster about 18 months ago or so. At first it appeared to be temperature related, but now it is pretty random. Probably off about 90% of the time - a delightful surprise when it actually works!
Just heard from our dealer - they said the problem is the gauge itself (not wiring or car computer), but that we can pass inspection without it.
Since they want $1,130 to replace it, we said we will continue to do without.
We use our info display to see how many miles we have remaining on a tank. Unfortunately, losing this display also loses the ability to track the service intervals (even when the gauge is working, it won't let me reset to zero after an oil change).
Otherwise, the car (with ~ 70K) is running fine.
I'm putting around 1500 miles a month on it, so we will see how it continues to hold up!
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Hutch
3rd Generation (2015+)
2
02-24-2017 10:48 AM
MyFreakFit
3rd Generation (2015+)
54
05-22-2015 12:42 PM
maxiking
1st Generation (GD 01-08)
1
12-29-2013 12:34 PM
MTLian
General Fit Talk
1
09-09-2013 07:11 PM
ecumotic
Fit Interior Modifications
0
12-11-2012 07:11 AM


Thread Tools
Search this Thread
Quick Reply: 2015 Honda Fit Fuel Gauge Display Failure


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.