3rd Generation (2015+) Say hello to the newest member of the Fit family. 3rd Generation specific talk and questions here.

Need help with spring install

  #1  
Old 04-26-2018, 04:23 AM
Member
Thread Starter
Join Date: Oct 2015
Location: NYC
Posts: 117
Need help with spring install

I was able to remove the strut assembly from the car. The top nut that's holding the assembly won't come loose, It just spins together with the long bolt in the center. I was not able to remove the spring from the strut. Anybody here encounter the same problem? TIA.
 
  #2  
Old 04-26-2018, 08:22 AM
GAFIT's Avatar
Member
5 Year Member
Join Date: Feb 2008
Location: Cleveland, GA
Posts: 3,815
I don't have direct experience with your model car, but there is usually a spot on the shaft that is not round where you can put a wrench on it to keep it from spinning.

If not, you'll need an impact.
 
  #3  
Old 04-26-2018, 08:31 AM
Member
Thread Starter
Join Date: Oct 2015
Location: NYC
Posts: 117
I got the 2015 EX 6 spd manual. I am gonna try again on my next day off, see if that works. Thanks BTW.
 
  #4  
Old 04-26-2018, 08:37 AM
Member
Join Date: Jul 2014
Location: Mason,Tenn
Posts: 228
strut help

Maybe this could help. Allen wrench and wrench on nut,



James
 
  #5  
Old 04-26-2018, 08:52 AM
Member
Thread Starter
Join Date: Oct 2015
Location: NYC
Posts: 117
@ James Butler, I am passed this part, my problem is removing the top nut to separate the spring from the strut.
 
  #6  
Old 04-26-2018, 09:16 AM
GAFIT's Avatar
Member
5 Year Member
Join Date: Feb 2008
Location: Cleveland, GA
Posts: 3,815
Like I said, I don't have direct experience with your model, but that should be the only nut that needs to be removed.

There should be three nuts that remove the assembly from the car and then that center nut allows disassembly of the spring and mount from the strut.

Looks like you need an allen wrench.
 
  #7  
Old 04-26-2018, 09:25 AM
Member
Thread Starter
Join Date: Oct 2015
Location: NYC
Posts: 117
@GAFIT, I'll try that next time thanks.
 
  #8  
Old 04-28-2018, 07:47 PM
kenchan's Avatar
Official Fit Blogger of FitFreak
5 Year Member
iTrader: (4)
Join Date: Dec 2007
Location: OG Club
Posts: 20,283
Originally Posted by [email protected] View Post
I was able to remove the strut assembly from the car. The top nut that's holding the assembly won't come loose, It just spins together with the long bolt in the center. I was not able to remove the spring from the strut. Anybody here encounter the same problem? TIA.
yah, i always tell my buddies to crack loose that nut while the strut is still on the car. makes for a night/day difference when you're ready to disassemble the unit off the car.
 
  #9  
Old 04-28-2018, 09:09 PM
Member
Join Date: Apr 2017
Location: Puyallup, WA
Posts: 255
I think I remember the part you're talking about, had to use an impact wrench. I don't do enough mechanic work to have quality air tools, but a 18v Ryobi from Home Depot that came with the drill I wanted had enough power to do the job.
 
  #10  
Old 04-30-2018, 02:49 PM
evilchargerfan's Avatar
Member
iTrader: (1)
Join Date: Apr 2018
Location: san diego
Posts: 2,020
Originally Posted by James Butler View Post
Maybe this could help. Allen wrench and wrench on nut,



James
this person replied with the answer you are asking for.

see figure C ... you need to shove an allen wrench in that hole to keep what is spinning to NOT spin .... once you achieve that.... NOW you can remove the nut
 
  #11  
Old 05-01-2018, 04:18 PM
datkidpatrick's Avatar
Member
5 Year Member
iTrader: (1)
Join Date: Apr 2008
Location: davie, fl
Posts: 33
Originally Posted by [email protected] View Post
@ James Butler, I am passed this part, my problem is removing the top nut to separate the spring from the strut.
use an air gun or use your foot to keep the strut from turning while laying the struct on the floor... oh and use a spring compressor...
 
  #12  
Old 05-01-2018, 11:55 PM
Member
Thread Starter
Join Date: Oct 2015
Location: NYC
Posts: 117
I was able to take it off. Trick is to not use the spring compressor, I just use my ryobi 20 volts impact wrench and it did the trick. The springs didn't have much tension on it. i am not sure about others though. I tried everything and took a gamble, it worked. But my sway bar end links passenger side bolts has a loose thread. I was not able to do the passenger side. =(
 
  #13  
Old 05-02-2018, 12:18 AM
evilchargerfan's Avatar
Member
iTrader: (1)
Join Date: Apr 2018
Location: san diego
Posts: 2,020
I did 1st side with spring compressor, noticed theres not much tension. for the 2nd side, didnt use the spring compressor and it was fine
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Bruce Huff
2nd Generation GE8 Specific DIY: Repair & Maintenance Sub-Forum
1
10-07-2015 02:06 PM
xTravisxEdgex
2nd Generation (GE 08-13)
16
11-13-2012 09:02 AM
MatT3T4
Fit Suspension & Brake Modifications
18
05-26-2011 11:38 PM
gd3vbp
Fit Suspension & Brake Modifications
10
04-07-2009 03:15 PM
dewthedew
Fit Suspension & Brake Modifications
24
11-21-2008 01:21 AM


Thread Tools
Search this Thread
Quick Reply: Need help with spring install


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.