Fit Suspension & Brake Modifications Threads discussing suspension and brake related modifications for the Honda Fit

AccuAir/ViAir Bagging--Now EPS is on and not steering well

  #1  
Old 01-24-2016, 12:28 AM
New Member
Thread Starter
Join Date: Jan 2016
Location: Toney, Alabama
Posts: 10
Question AccuAir/ViAir Bagging--Now EPS is on and not steering well

Over the past week I have been converting the stock suspension on 2009 Honda fit to AccuAir management with ViAir compressors. In the beginning stages of taking out stock, I accidentally left the CV axle/wheel assembly hanging on driver front side without support for too long and separated the drive shaft and inner CV joint. Got the axle reseated and back in. Put in the struts, attached everything. All is good with the air management and compressors but something has happened that has caused EPS light to come on, steering is stiff and sticks, and there is a rubbing/clicking kind of noise when I turn (even if the bags are full and with plenty of clearance). thoughts???
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
dosbirn
2nd Generation (GE 08-13)
8
01-10-2019 02:31 PM
justinb001
2nd Generation (GE 08-13)
8
09-11-2018 05:06 PM
JenR
2nd Generation (GE 08-13)
11
07-28-2016 11:02 PM
RandomKoko
Fit Suspension & Brake Modifications
30
09-14-2012 06:02 PM
luv4jdm
2nd Generation (GE 08-13)
7
02-23-2009 01:19 PM


Thread Tools
Search this Thread
Quick Reply: AccuAir/ViAir Bagging--Now EPS is on and not steering well


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.